Datacenter Issue Affecting Some ISP Proxy Subnets
Resolved
Apr 9, 2026 at 5:18am UTC
The vast majority, if not all, of our ISP Proxy Subnets have been restored and should be running normally again. If you were affected earlier, things should be back to normal on your end.
Affected services
Updated
Apr 9, 2026 at 2:42am UTC
Many subnets have been restored so far, we will continue restoring the rest.
Affected services
Created
Apr 8, 2026 at 11:23pm UTC
We're currently experiencing issues at one of our datacenters that's causing latency on some ISP Proxy subnets. You may notice slower performance on IPs within the affected ranges. We’re working to fix the problem as quickly as we can. We’ll share another update shortly.
Affected services